View Issue Details

IDProjectCategoryView StatusLast Update
0000191Silver Monkey[All Projects] Bug Reportspublic2018-04-15 09:49
ReporterDav_Edward 
Assigned Togerolkae 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product Version2.19. Beta 4 
Target Version2.19.x.Fixed in Version2.19. Beta 7 
Summary0000191: Trigger enters view targets everybody instead of proper target
DescriptionIf you use the following code:

(0:601) When a furre named {Name} enters the bots view,
        (5:44) follow the triggering furre

Instead of 'the triggering furre' being the named player that enters view, the bot instead sends the follow offer to ALL PLAYERS in view. This quirk likely affects many other Effects based on the Cause.
Steps To ReproduceUse the SpeakMonkey code:

(0:601) When a furre named {Name} enters the bots view,
        (5:44) follow the triggering furre.
TagsNo tags attached.

Relationships

Activities

gerolkae

2018-04-14 11:10

administrator   ~0000491

what happened was, The specified furre was checking for inRange was equal to wasInRange, wich would trigger all the time.

I refactored Furre.cs to have InRange HasEnteredView and HasLeftView.

Fix Candidate in 2.19 Beta 7

Issue History

Date Modified Username Field Change
2018-04-11 18:12 Dav_Edward New Issue
2018-04-12 20:29 gerolkae Assigned To => gerolkae
2018-04-12 20:29 gerolkae Status new => assigned
2018-04-12 20:29 gerolkae Target Version => 2.19.x.
2018-04-14 11:10 gerolkae Note Added: 0000491
2018-04-15 09:49 gerolkae Status assigned => resolved
2018-04-15 09:49 gerolkae Resolution open => fixed
2018-04-15 09:49 gerolkae Fixed in Version => 2.19. Beta 7